Friday, May 29, 2009

Small Busines Server 2008 in Vmware ESXi

It has been quite a while since I have added to my Blog; but since my employer decided to let their top Administrator go because they could not handle the economic downturn, I have found a new lease on life. Thanks employer!

A couple of weeks ago, on a Saturday, a bunch of Geeks gathered together to do a load fest of sorts of Windows Small Business Server 2008.

Each of us brought our own equipment and our best intentions to load the newest version of SBS. Each of us was trying different methods. One person was trying to do a migration of 2008 SBS to 2008 SBS but from physical to Virtual using MS hyper V. Another did a brand new install, but also on MS hyper V. The others, I don't remember but I believe they went standard on the hardware installs. I attempted SBS 2008 on a box running VMware ESXi 3 v4.

My Box was a thrown together: how cheap can I get this done type. I did use a brand new Intel Micro Board with 8 Gigs or RAM. Two Hard Drives: one 2.5 laptop Sata, and a 3.5 Samsung Terabyte drive. Oh yeah, make sure you have the VT turned on and the ACHI turned on.

I have never ever installed any version of SBS, so I was and consider myself a newbie to this OS. I am a seasoned techie when it comes to MS' other Server versions and Desktop OS(s). I am looking to learn more about this product.

Here is a step by step experience of what happened:

1. ESXi was installed on the 2.5 and working. I had put the second drive, the 3.5 Samsung in with the intention of putting all the Guests OS there; but ESXi would not see the second drive. So I booted the box with Gparted. Created a partition. Booted again to ESXi. Now I could see it and was able to add it to ESXi's data store.

2. Create VM using the Server 64 2008 choice. There is no choice for SBS 2008.

3. Could not boot VM from DVD:
  • Set VM boot to dvd 1st
  • Set time out to 10,ooo in VM so I can get to Bios better
  • Still could not connect so then:
  • I created an ISO of the SBS DVD
  • Using Veam, I moved it to iso folder I created on the first hd of the esxi
  • Connected the iso in the guest. It has some problems - I don't know why, but anyway I redid the boot order and it booted up.
4. Note: on Firefox, Going to the ESXi on browser, gave me Sec_error_ca_cert_invalid pop up.
  • In the address bar type about:config
  • goto browser.xul.error_pages_enabled and set it to true by double clicking
  • try again
  • accept certificate

5. Installed SBS 2008

6. Decided to put second NIC in server

7. Created second Virtual Switch

8. Attached SBS to the 2nd Virtual Switch

9. SBS Wizard - Internet
  • Because I did not have my own router (all the other guys did), It had me put in a static IP - It still bombed out, but I kept going and put a static also for server IP.
10. This is where I stopped at the load fest.

11. At home now - I put SBS back on the first Virtual Switch

12. Put SBS on my home network.

13. Ran Wizard
  • Connect to Internet
  • Disabled DHCP on m y router
  • Finish config for internet
14 . Did the Forefront One Care thing

15. Read Using the Windows SBS console.

16. Setup Internet address.

17. Configured Smart Host for Internet email.

18. Added two user accounts.

19. Attached a workstation and connected users to it.

20. SBS became my DHCP server automatically. It configured itself. The main thing is that you have to make sure that the DCHP is turned off on your router.

This is where I stopped for now. I plan to wipe it and start again. I need to get the Exchange piece going, but I need a second static IP from ISP for home because my Home Server is on my only one. Oh, yeah Home Server. That is a pretty cool product.

See you soon.

Delco